How do you run simulated tests in TestSuite?

QUESTION

 

How do you run simulated tests in TestSuite?

 

 

ANSWER 

 

To run simulated tests in TestSuite you need to put the 793 software in simulation mode first.  It is recommended that you test the procedure after adding each new process and correct things as you go. If you wait until you have written the entire test then try to run it in simulation it will be much more complicated to figure out what’s not working.  If you’ve already written the entire procedure you can disable processes then enable them one at a time to retest.

 

 

Putting 793 software into simulation mode

 

Start > All Programs > MTS 793 Software >Tools >Demo System Loader. 

 

This will open two command prompt windows that will minimize to the taskbar.  Don’t close these.  Afterwards, you should be able to open Station Manager like normal. 

 

Once you are done using the software in demo mode you can close Station Manager.  Once the “Closing station, please wait” window disappears you can run Demo System Unloader:

 

Start >All Programs >MTS 793 Software >Tools > Demo System Unloader. 

 

This will put the software back to non-simulation mode. 

 

Important:  To successfully run in simulation you need to configure parameters in station setup first even if you plan to run simulated tests in another application like TestSuite.

 

 

Parameter Settings Running in Demo (Simulation Mode 793)

 

  1. Set Total gain of the DUCs to 10.0 as shown in the following screenshot (Figure 1).  It’s an unfortunate quirk that comes from the way that the simulation mode internal actuator model works where anything else than a Total gain of 10 will make the input signals saturate in a way that doesn’t make sense unless you understand what’s happening internally.

 

Figure 1 – Total Conditioner gain of 1 for simulation mode

 

 

  1. In general the PID gains need to be low, i.e., P=1.0 for simulation mode to work reasonably.  If the user has them set high to get the desired performance with their real system, they may need to detune them to get decent performance in simulation mode. 

 

  1. Make sure both the signal conditioner and servovalve polarities are either Normal or Invert.

 

  1. If feedback is outside of the calibrated full range an gives you an invalid feedback error interlock preventing you from turning on the HSM do this:

 

Display menu > Station Setup > Station Signals > Auto Offset all signals > File menu > Save Parameters > Exit > Reopen Station Manager.

 

This will set all feedback values back to zero and within the calibrated range allowing you to reset and clear the invalid feedback interlock.

 

 

 

 

How to run simulation tests in TestSuite without having to simulate clearing interlocks and turning on the HPU and HSM first

 

In Explorer, click on Test Definition > Command Settings > Power > Required to Run: > Select Off (Figure 2).

 

Figure 2 – Command Settings > Required to Run:  > Off 

 

 

 

 

How to monitor your test progress in simulation

 

 

1. Click on the Test-Run Display (Figure 3).

 

Figure 3 –Test-Run Display

 

2. From the Toolbox drag Test Procedure and Signal Scope to the Designer area (Figure 4).

 

cid:image008.png@01D53648.AF5DC140

Figure 4– Adding Test Procedure and Signal Scope to the Test-Run Display

 

3. Arrange the Test Procedure and Signal Scope until they look the way you want in the Preview window (Figure 5).

Figure 5 – Preview of Test-Run Display as it will look like when the test is running

 

K
Keary is the author of this solution article.

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.